npm i nodejs-mod_wurfl fails to install

Questions about the ScientiaMobile WURFL APIs

npm i nodejs-mod_wurfl fails to install

Postby AskSearch » Wed Feb 08, 2017 4:47 pm

OS X 10.12.2
node 4.6.0
npm 2.15.9

Failed at the nodejs-mod_wurfl@1.6.4 install script 'node-gyp rebuild'
fatal error: 'wurfl/wurfl.h' file not found
Last edited by AskSearch on Wed Feb 08, 2017 6:10 pm, edited 1 time in total.
AskSearch
 
Posts: 4
Joined: Tue Nov 25, 2014 6:49 pm

Re: npm i nodejs-mod_wurfl fails to install

Postby aaronp » Wed Feb 08, 2017 5:05 pm

Hi David,

Thank you for letting us know. We are taking a look into the issue and will check back in with you as soon as we have an update. In the meantime, if you have not already done so, are you able to verify that the libwurfl (C API) prerequisite has been installed (the versions for libwurfl and the Node.js module should match)?

Moving forward, please do not hesitate to reach out to support@scientiamobile.com for any requests you may have and a ticket will be created for you.

Thanks,

Aaron
aaronp
 
Posts: 132
Joined: Wed Dec 09, 2015 12:39 pm

Re: npm i nodejs-mod_wurfl fails to install

Postby AskSearch » Wed Feb 08, 2017 6:09 pm

I am currently on OS X 10.12.2. What is the best way to install libwurlf? I have this link but it is dead: https://filex.scientiamobile.com/user/download
AskSearch
 
Posts: 4
Joined: Tue Nov 25, 2014 6:49 pm

Re: npm i nodejs-mod_wurfl fails to install

Postby aaronp » Wed Feb 08, 2017 6:18 pm

In order to get the package, you will want to begin by logging into your ScientiaMobile account in the homepage, then go to:

My Account -> File Management -> Products -> WURFL InFuze

The files will be located in there. However, I do see that you are on an older version (v1.6.4), so I have uploaded the libwurfl v1.6.4 file into the WURFL InFuze directory. Do note that support for v1.6.4 for MacOSX only goes up to v10.10 so it may be of interest for you to update to v1.8.3.0

The following page is the documentation for installing libwurfl:
https://docs.scientiamobile.com/documen ... user-guide
aaronp
 
Posts: 132
Joined: Wed Dec 09, 2015 12:39 pm

Re: npm i nodejs-mod_wurfl fails to install

Postby AskSearch » Wed Feb 08, 2017 6:34 pm

I tried installing different programs, only 1.8.3 did not fail.

However, I get this error on npm install nodejs-mod_wurfl@1.8.3:
npm WARN optional dep failed, continuing nodejs-mod_wurfl@1.8.3

And this error on npm install nodejs-mod_wurfl@1.6.4 (also 1.6.5):

../src/wurfl_nodejs_module.cpp:3:10: fatal error: 'wurfl/wurfl.h' file not found

What node modules can be used with wurlflib 1.8.3? And how do I get them?
AskSearch
 
Posts: 4
Joined: Tue Nov 25, 2014 6:49 pm

Re: npm i nodejs-mod_wurfl fails to install

Postby aaronp » Thu Feb 09, 2017 10:19 am

The Node.js module you will want to use after installing libwurfl v1.8.3 would be Node.js v1.8.3

The package for both libwurfl and Node.js v1.8.3 can be found in your File Manager under the InFuze directory.
aaronp
 
Posts: 132
Joined: Wed Dec 09, 2015 12:39 pm


Return to ScientiaMobile WURFL API Support

Who is online

Users browsing this forum: No registered users and 1 guest