Scala WURFL 1.9.0.0 pom invalid

Scala WURFL 1.9.0.0 pom invalid

Postby trickydee » Sun Jul 23, 2017 1:38 pm

Hi, it seems the artefact published here:
http://maven.scientiamobile.com:8081/ne ... .9.0.0.pom
contains the wrong scala version referenced inside (2.11) which launches this when trying to build anything with sbt (here I use a proxy for your repo).

Code: Select all
[error] (*:update) sbt.ResolveException: unresolved dependency: com.scientiamobile.wurfl#wurfl-scala_2.12;1.9.0.0: java.text.ParseException: inconsistent module descriptor file found in 'http://maven:8082/nexus/content/repositories/scientiamobile/com/scientiamobile/wurfl/wurfl-scala_2.12/1.9.0.0/wurfl-scala_2.12-1.9.0.0.pom': bad module name: expected='wurfl-scala_2.12' found='wurfl-scala_2.11';
[error] Total time: 206 s, completed Jul 23, 2017 6:27:04 PM
trickydee
 
Posts: 32
Joined: Fri Jul 17, 2015 8:58 am

Re: Scala WURFL 1.9.0.0 pom invalid

Postby aaronp » Mon Jul 24, 2017 11:22 am

Thanks for letting us know. My engineering team is looking into the issue and I'll check back in with you as soon as I hear back.

Thanks,

Aaron
aaronp
 
Posts: 189
Joined: Wed Dec 09, 2015 12:39 pm

Re: Scala WURFL 1.9.0.0 pom invalid

Postby aaronp » Wed Jul 26, 2017 11:04 am

We've updated the artifact so you should now get the correct version of Scala (2.12). Let me know if there is anything else you need assistance with.

Thanks,

Aaron
aaronp
 
Posts: 189
Joined: Wed Dec 09, 2015 12:39 pm


Return to Scala API

Who is online

Users browsing this forum: No registered users and 1 guest

cron