Dependencies for scala artefact 1.8.2.0 seems to be wrong

Dependencies for scala artefact 1.8.2.0 seems to be wrong

Postby trickydee » Sun Dec 04, 2016 12:53 pm

When trying to reference wurfl-scala_2.11:1.8.2.0 in sbt it's trying to reference and resolve `com.scientiamobile.wurfl#wurfl-scala_2.11;1.8.2.0!wurfl-scala_2.11.java-source` which fails.
Looking at
~/.ivy2/cache/com.scientiamobile.wurfl/wurfl-scala_2.11/ivy-1.8.2.0.xml and
~/.ivy2/cache/com.scientiamobile.wurfl/wurfl-scala_2.11/ivy-1.8.1.0.xml there seem to be a lot of differences, are we sure the artefact has been generated properly?

Code: Select all
 ~/wurfl-service /> develop ●✚ > diff ~/.ivy2/cache/com.scientiamobile.wurfl/wurfl-scala_2.11/ivy-1.8.2.0.xml ~/.ivy2/cache/com.scientiamobile.wurfl/wurfl-scala_2.11/ivy-1.8.1.0.xml
5c5
<       revision="1.8.2.0"
---
>       revision="1.8.1.0"
7c7
<       publication="20161122173222"
---
>       publication="20161128013941"
9,10c9,26
<       <description homepage="" />
<       <e:sbtTransformHash>858a3014e4a5ce6d7bccbd86ff9d3f6543dbf080</e:sbtTransformHash>
---
>       <license name="SMC" />
>       <description homepage="http://sourceforge.net/projects/wurfl/files/WURFL%20Scala%20API/">
>       Wireless Universal Resource File core API
>       </description>
>       <m:properties__testng-version>5.14.10</m:properties__testng-version>
>       <m:properties__project.reporting.outputEncoding>UTF-8</m:properties__project.reporting.outputEncoding>
>       <m:properties__slf4j-version>1.6.1</m:properties__slf4j-version>
>       <m:properties__ant-root-folder>ant</m:properties__ant-root-folder>
>       <m:properties__logback-version>0.9.28</m:properties__logback-version>
>       <m:properties__project.build.sourceEncoding>UTF-8</m:properties__project.build.sourceEncoding>
>       <m:properties__scala.version>2.11.1</m:properties__scala.version>
>       <m:properties__scala.tools.version>2.11</m:properties__scala.tools.version>
>       <m:properties__wurfl-scala-wrapper-evolution>1.1</m:properties__wurfl-scala-wrapper-evolution>
>       <e:sbtTransformHash>d0091704b636ec9280607c6e7c0cf07bc8df89f3</e:sbtTransformHash>
>       <m:properties__maven.compiler.target>1.6</m:properties__maven.compiler.target>
>       <m:properties__wurfl-java.version>${project.version}</m:properties__wurfl-java.version>
>       <m:maven.plugins>net.alchim31.maven__scala-maven-plugin__3.1.3|org.scala-tools__maven-scala-plugin__2.15.2|org.apache.maven.plugins__maven-source-plugin__null|org.apache.maven.plugins__maven-surefire-plugin__2.7|org.scalatest__scalatest-maven-plugin__1.0</m:maven.plugins>
>       <m:properties__maven.compiler.source>1.6</m:properties__maven.compiler.source>
25c41
<       <artifact name="wurfl-scala_2.11" type="java-source" ext="java-source" conf="master"/>
---
>       <artifact name="wurfl-scala_2.11" type="jar" ext="jar" conf="master"/>
26a43,59
>    <dependencies>
>       <dependency org="org.scala-lang" name="scala-library" rev="2.11.1" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="commons-collections" name="commons-collections" rev="3.2.1" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="commons-lang" name="commons-lang" rev="2.6" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="javax.servlet" name="servlet-api" rev="2.4" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="net.sf.jsr107cache" name="jsr107cache" rev="1.1" force="true" conf="optional->compile(*),master(compile)"/>
>       <dependency org="net.sf.ehcache" name="ehcache-core" rev="2.4.3" force="true" conf="optional->compile(*),master(compile)"/>
>       <dependency org="org.slf4j" name="slf4j-api" rev="1.6.1" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="com.scientiamobile.wurfl" name="wurfl" rev="1.8.1.0" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="ch.qos.logback" name="logback-classic" rev="0.9.28" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="org.testng" name="testng" rev="5.14.10" force="true" conf="test->runtime(*),master(compile)"/>
>       <dependency org="org.easymock" name="easymock" rev="2.3" force="true" conf="test->runtime(*),master(compile)"/>
>       <dependency org="org.codehaus.jackson" name="jackson-core-asl" rev="1.8.2" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="org.codehaus.jackson" name="jackson-mapper-asl" rev="1.8.2" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>       <dependency org="junit" name="junit" rev="4.8.1" force="true" conf="test->runtime(*),master(compile)"/>
>       <dependency org="org.scalatest" name="scalatest_2.11" rev="2.2.6" force="true" conf="compile->compile(*),master(compile);runtime->runtime(*)"/>
>    </dependencies>
trickydee
 
Posts: 32
Joined: Fri Jul 17, 2015 8:58 am

Re: Dependencies for scala artefact 1.8.2.0 seems to be wron

Postby trickydee » Sun Dec 04, 2016 1:10 pm

To try and help with the investigation, the difference between
http://maven.scientiamobile.com:8081/ne ... .8.0.0.pom
and
http://maven.scientiamobile.com:8081/ne ... .8.2.0.pom
seems rather dramatic.

Can it be perhaps you're publishing the artefact as a scondary step via mvn deploy:deploy-file ...? In that case maybe passing -DgeneratePom=false would not generate this new invalid pom.
trickydee
 
Posts: 32
Joined: Fri Jul 17, 2015 8:58 am

Re: Dependencies for scala artefact 1.8.2.0 seems to be wron

Postby aaronp » Mon Dec 05, 2016 5:00 pm

Hi Joel,

Thanks for providing the information. We will work to reproduce your issue with the Scala artifacts and will check back in with you as soon as we have an update.

Thanks,

Aaron
aaronp
 
Posts: 185
Joined: Wed Dec 09, 2015 12:39 pm

Re: Dependencies for scala artefact 1.8.2.0 seems to be wron

Postby aaronp » Wed Dec 07, 2016 11:29 am

Hi Joel,

The issue has been corrected and after testing on a demo project, everything now compiles and runs correctly. Are you able to try running the API once more and let me know if `com.scientiamobile.wurfl#wurfl-scala_2.11;1.8.2.0!wurfl-scala_2.11.java-source` passes?

Thanks,

Aaron
aaronp
 
Posts: 185
Joined: Wed Dec 09, 2015 12:39 pm


Return to Scala API

Who is online

Users browsing this forum: No registered users and 1 guest

cron